2016 both Front Heated/Cooled seats help request
Results 1 to 10 of 10
Like Tree2Likes
  • 1 Post By Scooter2016limited4WD
  • 1 Post By Scooter2016limited4WD

Thread: 2016 both Front Heated/Cooled seats help request

  1. #1
    Junior Member Scooter2016limited4WD's Avatar
    Join Date
    Dec 2019
    Posts
    8
    Member #
    5867
    Liked
    2 times

    2016 both Front Heated/Cooled seats help request

    Both front seats heating and cooling stopped working at the same time.
    From what I've read all over, it is NOT the switch(s); both switches light up, and work properly (three bars, then two then one) and stay lit on both sides, for both functions, and it reflected also in the Sync screen.
    1st troubleshoot potential = FUSE (72) in engine fuse box ...it is fine, put in new one, swapped with windshield wiper fuse (same 30A) so i know it is working.
    2nd troubleshoot potential = Seat Control Module; Cannot locate any information about this year's Control Module online; location or even the specific part number.
    - Location = Under driver's seat is the ONLY control module visible underneath either the driver OR passenger seats.
    - Part # = GU5T - 14C708 - HK; typing this into Google search results in ZERO direct matches. This is a six (6) plug module. I can't find any wiring diagrams, etc. online.
    I pulled the module, checked all the connectors and reinstalled (no burnt looking wires as some other heated/cooled seats in older model ford/lincolns have indicated a ground wire gets overloaded)
    3rd troubleshoot potential = a week or so prior to both seats no longer working, the driver side blower fan was making a noise.

    Any year and part specific diagrams, directions to replacement part module, or directions on what wires to test with digital multi-meter would be greatly appreciated.
    Name:  2016 DSM Driver Front2.JPG
Views: 66
Size:  190.9 KBName:  2016 DSM Driver Front.JPG
Views: 73
Size:  241.3 KB

  2. #2
    Junior Member gjkrisa's Avatar
    Join Date
    Mar 2019
    Location
    Fairbanks, ak
    Posts
    6
    Member #
    5379
    Liked
    2 times
    If you unplug that brown plug most likely you will find a burnt pin
    Others have just fixed the burnt pin and been fine
    Since mine was still under warranty I had them replace it.

    I'm wrong the burnt pin on mine was a long black plug
    You can see it in this photo the black and white strip
    This is under the passenger seat
    Sent from my Pixel 4 XL using Tapatalk
    Last edited by gjkrisa; 01-02-2020 at 11:05 AM.

  3. #3
    Junior Member Scooter2016limited4WD's Avatar
    Join Date
    Dec 2019
    Posts
    8
    Member #
    5867
    Liked
    2 times
    Thanks for the comment and picture. I removed the module and did a cursory inspection of the pins and all looked fine. I will remove it again and do a more detailed inspection. Man I hope that i missed it the first time and this is the problem.

  4. Remove Advertisements
    FordExplorer.org
    Advertisements
     

  5. #4
    Junior Member gjkrisa's Avatar
    Join Date
    Mar 2019
    Location
    Fairbanks, ak
    Posts
    6
    Member #
    5379
    Liked
    2 times
    Quote Originally Posted by Scooter2016limited4WD View Post
    Thanks for the comment and picture. I removed the module and did a cursory inspection of the pins and all looked fine. I will remove it again and do a more detailed inspection. Man I hope that i missed it the first time and this is the problem.
    Do you have access to forscan it may be able to tell you if the module is working or not?

    Sent from my Pixel 4 XL using Tapatalk

  6. #5
    Junior Member Scooter2016limited4WD's Avatar
    Join Date
    Dec 2019
    Posts
    8
    Member #
    5867
    Liked
    2 times
    My OBDII reader/adapter doesn't work with Forscan, so at this point I don't have access. If I did, not sure I'd know what I am looking for. I may invest in one anyway in order to change some of the annoying Ford features like the double honk when vehicle running and the key gets away from the vehicle. I did check all of the wiring harnesses up close and there is no scorching or damage to any of them.

  7. #6
    Junior Member Scooter2016limited4WD's Avatar
    Join Date
    Dec 2019
    Posts
    8
    Member #
    5867
    Liked
    2 times
    Just ordered a brand new control module. Will post results after it arrives post Jan. 9.

  8. #7
    Junior Member Scooter2016limited4WD's Avatar
    Join Date
    Dec 2019
    Posts
    8
    Member #
    5867
    Liked
    2 times
    Brand new module arrived. Plugged it in. Everything works...except the heated/cooled seats. It is something else. Going to replace the driver blower motor that was making noise prior to both sides stopping function. This part is DU5Z-19N550-D, $107 @ getoempart.com
    gjkrisa likes this.

  9. #8
    Junior Member Scooter2016limited4WD's Avatar
    Join Date
    Dec 2019
    Posts
    8
    Member #
    5867
    Liked
    2 times
    Update. I didn't replace the driver side blower motor as I got impatient and wanted a definitive resolution. Brought it to local shop where I've had past electrical repairs with positive experience. The engine bay Fuse Box / Junction Box / Power Distribution box located on the driver side near the battery, with the accessible black top, and houses the fuse for the climate controlled seats. The fuse was good, as previously mentioned, however the connector underneath the fuse (#72) was charred, not functioning properly. The power at the seats was a constant 1v no matter if the switch was on or off. My interpretation of this is that the DCM may have placed the seats into a protect mode. It ended up being a fairly expensive repair because the diagnosis took a while and then instead of purchasing a new box, we did a work around. It seems Ford has some difficulty with connectors from the research i've done just on this issue alone. If I had taken off the fuse box initially and inspected it, i could have bought a used one for around $200 and replaced it myself.
    gjkrisa likes this.

  10. #9
    Junior Member Jakuzi1's Avatar
    Join Date
    Feb 2020
    Posts
    0
    Member #
    5991
    Liked
    1 times
    Hi I just posted a thread about my 2017 explorer having the same problem. I have some questions though if you don't mind about your experience. You or others mentioned that the controller is under the passenger seat but after removing my seat I didn't find any control module. Just the blower and power seat plug. I do have one under my driver seat but mine look different to the pics shown on your post. There are three under my seat the main control with two large plugs one with one plug and another with small plugs and an air tube coming out Wich I assume is for the lumbar. The dealer told me it was a short in the heated seats control module but would not give me a part number or location. Would you happen to know which module and where it is? In the mean time I'm going to take a look at the fuse box to see if maybe I missed something because I looked at it when I checked the fuse and I didn't see anything. Any help would be appreciated. Thank

  11. #10
    Junior Member Scooter2016limited4WD's Avatar
    Join Date
    Dec 2019
    Posts
    8
    Member #
    5867
    Liked
    2 times
    Quote Originally Posted by Jakuzi1 View Post
    Hi I just posted a thread about my 2017 explorer having the same problem. I have some questions though if you don't mind about your experience. You or others mentioned that the controller is under the passenger seat but after removing my seat I didn't find any control module. Just the blower and power seat plug. I do have one under my driver seat but mine look different to the pics shown on your post. There are three under my seat the main control with two large plugs one with one plug and another with small plugs and an air tube coming out Which I assume is for the lumbar. The dealer told me it was a short in the heated seats control module but would not give me a part number or location. Would you happen to know which module and where it is? In the mean time I'm going to take a look at the fuse box to see if maybe I missed something because I looked at it when I checked the fuse and I didn't see anything. Any help would be appreciated. Thank
    Do you have the Climate Control seats (Heated/Cooled) or just the Heated? I am guessing Heated only? Not for certain if it isn't exactly the Year, model and options I have, but going to be fairly confident the Control Module is under the driver seat. I suggest taking pictures of the control module and Googling the part number. You may be able to buy one online fairly inexpensive and swap it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •