2019 Explorer DEAD Battery now Tranny
Results 1 to 2 of 2
  1. #1
    Junior Member Tagg's Avatar
    Join Date
    Apr 2020
    Posts
    1
    Member #
    6141

    2019 Explorer DEAD Battery now Tranny

    Ok, we have a 2019 Explorer XLT that the battery went dead on after setting for aprox 5 weeks without being used. After getting it restarted by jumping and running the unit for about 40 miles over 2 days, the CEL light is On and also the Wrench light showing a PowerTrain problem. The Wrench light showing a PowerTrain problem says in manual. The manual then tells you to contact service dept. What a ******* answer after telling you to see manual. What is the correct procedure without taking it to a dealer (being they are closed here in Pennsylvania) Thanks to our Governor. Is it just better to keep driving it, will it Relearn it's Program ? The tranny appears to Not Downshift properly and clunking when moving from a stopped position, also the Sport shift mode doesn't want to change gears when trying to downshift. Thanks.

  2. #2
    Member elyk864's Avatar
    Join Date
    Feb 2018
    Location
    Arizona
    Posts
    93
    Member #
    4162
    Liked
    13 times
    I'd put a new battery in it and try again. I know my Focus ST does some really strange stuff when a battery is starting to let go. I don't know if the Explorer platform is the same or not.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •