A/C different temperatures - 2017 Explorer
Results 1 to 4 of 4
  1. #1
    Junior Member Kanavey's Avatar
    Join Date
    Jul 2020
    Posts
    3
    Member #
    6447

    A/C different temperatures - 2017 Explorer

    2017 Ford Explorer has different temperatures coming from the 4 front vents. The drivers side is about 10 degrees warmer than the passenger side. I have tried cycling all the vents, temperature controls, defroster, etc. Run them up and down with no change when I go back to maximum AC with a LO setpoint.

    Found a post that said to push the climate control/defrost buttons at the same time, then climate control again. Tried that...heard the vents cycle, but still back to difference in temperature.

    Looking for more ideas. Maybe a damper actuator issue? Can they be misaligned?

    Also, does anyone have a good diagram that shows the different connections under the drivers side dashboard. Maybe the damper actuator needs rezeroed?

    Thoughts?
    Last edited by Kanavey; 07-16-2020 at 10:07 AM.

  2. #2
    Senior Member elyk864's Avatar
    Join Date
    Feb 2018
    Location
    Arizona
    Posts
    107
    Member #
    4162
    Liked
    15 times
    Try to disconnect the battery and see if that resets it.

  3. #3
    Junior Member Kanavey's Avatar
    Join Date
    Jul 2020
    Posts
    3
    Member #
    6447
    Quote Originally Posted by elyk864 View Post
    Try to disconnect the battery and see if that resets it.
    Tried...and denied. No change. Couldn't be so simple!

  4. Remove Advertisements
    FordExplorer.org
    Advertisements
     

  5. #4
    Junior Member Kanavey's Avatar
    Join Date
    Jul 2020
    Posts
    3
    Member #
    6447
    Added a 12oz can of freon...and temps have dropped 15 degrees with a 3 degree delta, so I am going to say that this is fixed...for now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •