2002 explorer fuel pump
Results 1 to 6 of 6
Like Tree1Likes
  • 1 Post By 4slash6

Thread: 2002 explorer fuel pump

  1. #1
    Junior Member 4slash6's Avatar
    Join Date
    Jun 2020
    Posts
    5
    Member #
    6371
    Liked
    2 times

    2002 explorer fuel pump

    hello, 1st post. just an observation really. I am original owner 02 explorer 4.0 130k miles now. Saw a thread once claimed best to use motorcraft fuel pump over cheap replacements....well, maybe but I am about to put in what will be the 4th pump. I installed the last one @ 99k miles. lasted 6 years. but @ almost $400.00 for the part, I am finally going to go with a much less expensive brand. ultrapower $68.00 shipped, rock auto. yes, I did cut the access hole last time to make things easy and fast for me, not to mention any worries of everything else breaking I touch underneath after 18 MN winters of salt etc. I can purchase 6 of these for $$ of the FORD puimp. Time will tell how long it will last. But how long will the rest of the vehicle last?? I love this suv And know when the pump is getting tired, hot day, wont start 1st turn of key and sometimes only after it cools for a while, but I like it does not strand me to a tow bill. dealer swapped out 1st pump under warranty. I have done last two. I believe this is a common failure in climates that see wide temperature swings. That said, this has been a great vehicle.

  2. #2
    Senior Member elyk864's Avatar
    Join Date
    Feb 2018
    Location
    Arizona
    Posts
    114
    Member #
    4162
    Liked
    15 times
    You shouldn't be going through that many pumps. What fuel are you putting in it? Check the fuel filter also.

  3. #3
    Junior Member 4slash6's Avatar
    Join Date
    Jun 2020
    Posts
    5
    Member #
    6371
    Liked
    2 times
    I agree, 1st pump did go out right after I filled up at a gas station, maybe 2 years old 20k miles? Read that keeping a full tank aids greatly in cooling the pump. I have kept it over 1/4th since. I also have heard a restrictive fuel filter can make the pump work harder. I have had zero issues with run performance year round. Plugs and wires at 75k, trans was rebuilt by dealer @ 48k along with rear diff. bearings. I swapped rear struts and coil assembly as coil was broke early on @ driver side. ( a known/ common failure). 4 wheel bearings, tie rod ends and sway bar links. Thats about it except for brake service... I will swap that fuel filter and cut old one open to inspect some time soon, thanks for input.
    elyk864 likes this.

  4. Remove Advertisements
    FordExplorer.org
    Advertisements
     

  5. #4
    Junior Member dejen3303's Avatar
    Join Date
    Oct 2018
    Location
    Olympia, WA
    Posts
    13
    Member #
    5091
    Liked
    1 times
    "Read that keeping a full tank aids greatly in cooling the pump. I have kept it over 1/4th since."
    I have been driving company supplied Econoline and now a 2016 Transit van (100K on this one) for 25 years. I've had some vehicles replaced at 90k and one I took to 130k. I've been through quite a few Ford vehicles. I never fuel up until the tank is empty. Many times I will drive until the fuel light comes on. Not one has ever needed a fuel pump replaced. All I know about that is my experience.
    They've all had very few problems and almost no warranty work.
    The Transit is the reason I purchased the Explorer. Smooth as butter and the 3.5 Ecoboost is fantastic.

  6. #5
    Junior Member 4slash6's Avatar
    Join Date
    Jun 2020
    Posts
    5
    Member #
    6371
    Liked
    2 times
    Agreed for your year vehicle...what I had heard was this was a late 90"s early 2000's explorer problem.............. I have a 1990 dodge ramcharger 164k miles , original pump. I have owned ford vehicles my whole life (am 62) and retired from Ford. never had this problem with any of the others. I have the new fuel filter, anxious to see how dirty old one is. inside of tank was not bad at all for the age. (2002). https://www.carproblemzoo.com/ford/e...p-problems.php
    Last edited by 4slash6; 06-28-2020 at 07:08 PM.

  7. #6
    Junior Member 4slash6's Avatar
    Join Date
    Jun 2020
    Posts
    5
    Member #
    6371
    Liked
    2 times
    Update: Finally today got around to swapping the original fuel filter (2002 130k miles) process: 1st heat shield came out easy, shield over pump mount rusty and just spins the nuts. angle grinder made quick work of them. takes a little muscle and about 10:00 of fidgeting to get the 3 lines disconnected. New filter went in easy, new bolts and nuts. All back together no leaks. cut original filter open and it was really dirty. I am hoping that this has been cause of some of my premature pump failures. if I dragged my thumb over the paper part of the filter, once opened up, a black film was present. Inside of tank looked good except for a few sporadic pieces of dirt. here is a pic.
    Attached Images Attached Images  

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •