Belt squeal from 2013 explorer sport
Results 1 to 3 of 3
  1. #1
    Junior Member bensylrm's Avatar
    Join Date
    Dec 2016
    Location
    Where the trail has led me, for now.
    Posts
    16
    Member #
    1290
    Liked
    6 times

    Belt squeal from 2013 explorer sport

    As the title suggests I have a 2013 explorer sport, and the belt has been squealing on it for a bit. I notice it mostly when it's raining or the belt gets wet. Has anyone attempted to replace the belt tensioner, or is it commonly fixed by replacing the belt and leaving it at that?

    Sent from my ONEPLUS 6 using Tapatalk

  2. #2
    Member Ohio Snake's Avatar
    Join Date
    May 2018
    Location
    Galena
    Posts
    41
    Member #
    4729
    Liked
    8 times
    I’d replace the belt and inspect the tensioner and other pullies.

    I had cobra mustang with an OEM aluminum tensioner that was bent after one year. Obvious defect which Ford had a recall to replace said tensioner with a steel unit. Hopefully they learned a lesson since then.

    Just inspect the tensioner for proper operation and replace if needed.


    Sent from my iPad using Tapatalk

  3. #3
    Junior Member bensylrm's Avatar
    Join Date
    Dec 2016
    Location
    Where the trail has led me, for now.
    Posts
    16
    Member #
    1290
    Liked
    6 times
    Yeah, that was the general plan. I've seen some videos of how the job goes, and I'm trying to figure out how to get to the tensioner should it need to be replaced. There isn't any room in there to get to work on it. I wasn't sure if removing the passenger side front tire and wheel well would be in order or if there was a better way to get to it.

    Sent from my ONEPLUS 6 using Tapatalk

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •