Search Results - Ford Explorer Forum

Search:

Type: Posts; User: nikitaso

Search: Search took 0.02 seconds.

  1. Replies
    0
    Views
    378

    stuck connector

    any tips how to remove it? what if it geta damaged?

    red thingy is open and still would not disconnect
  2. Replies
    5
    Views
    2,049

    i have 2013 xlt, installed CAI and SCT tuner, i...

    i have 2013 xlt, installed CAI and SCT tuner, i wouldnt say there is no difference.. but not like its launching

    it did gain better gas milege, avg 19 highway+city and 22-23 highway (even higher)...
  3. Replies
    14
    Views
    6,812

    I m curious if sticker survived 80k miles,...

    I m curious if sticker survived 80k miles, passenger side doesn't have one. not many stickers under in general

    just curious if axle was replaced

    Sent from my MHA-L29 using Tapatalk
  4. Replies
    14
    Views
    6,812

    that "play" stopped, then came back later Sent...

    that "play" stopped, then came back later

    Sent from my MHA-L29 using Tapatalk
  5. Replies
    14
    Views
    6,812

    here's video and some clunking noise, that noise...

    here's video and some clunking noise, that noise and play disappeared after a little driving, but car vibrates like no tomorrow (after 40mph)


    https://youtu.be/PfaIYZAkWJU

    also left axle has...
  6. Replies
    14
    Views
    6,812

    why no clicking noise or any play when you...

    why no clicking noise or any play when you inspect them?
    thanks

    Sent from my MHA-L29 using Tapatalk
  7. Replies
    14
    Views
    6,812

    did transmission flush today and still vibrates ...

    did transmission flush today and still vibrates

    Sent from my MHA-L29 using Tapatalk
  8. Replies
    14
    Views
    6,812

    M is like manual Sent from my MHA-L29 using...

    M is like manual

    Sent from my MHA-L29 using Tapatalk
  9. Replies
    14
    Views
    6,812

    when it happened i shifted into M mode and...

    when it happened i shifted into M mode and vibration became better almost gone

    also noticed when accelarate from 0 and switch to M mode it would show 5 gear, but im going like 15 mph

    Sent from...
  10. Replies
    14
    Views
    6,812

    2013 XLT AWD not steering wheel or seat its...

    2013 XLT AWD
    not steering wheel or seat
    its coming engine almost, feels in whole car but mostly in front end

    I read it could be harmonic balancer. It's not transmission as accelarates just...
  11. Replies
    14
    Views
    6,812

    Vibration in front

    im getting vibration when going uphill, speeds over 45mph, it can get to point that feels like its going fall apart.
    It only starts 40-60 mins into road trip.
    Mechanic checks joints, everything...
Results 1 to 11 of 11