Ford Explorer Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello, I need some help here as I am stumped. I drove my car and received the check charging system light and steering got tight. So I did some research and ended up changing the Alternator which was bad, new belt, tensioner and battery. So I figured my issue was solved but I was wrong. So the steering is fine, the car rides fine at regular speeds but I am still getting the check charging system light. I also get a misfire/sputter on idle. I have changed all the coil packs and plugs also. I have had a bunch of issues with this vehicle including spending 2k with the dealer in Nov on a Power steering failure that tightened up on my wife on the Highway. I dont wanna keep dumping alot of money as I have a feeling this thing is on a downward slide. I appreciate the help

Tony
 

·
Registered
Joined
·
1 Posts
You ever figure it out?

Hello, I need some help here as I am stumped. I drove my car and received the check charging system light and steering got tight. So I did some research and ended up changing the Alternator which was bad, new belt, tensioner and battery. So I figured my issue was solved but I was wrong. So the steering is fine, the car rides fine at regular speeds but I am still getting the check charging system light. I also get a misfire/sputter on idle. I have changed all the coil packs and plugs also. I have had a bunch of issues with this vehicle including spending 2k with the dealer in Nov on a Power steering failure that tightened up on my wife on the Highway. I dont wanna keep dumping alot of money as I have a feeling this thing is on a downward slide. I appreciate the help
 
1 - 3 of 3 Posts
Top