Ford Explorer Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a 2013 Limited. The rear interior lights and electric 3rd row seat stopped working. We changed the fuse that was blown and they worked for the day and the fuse blew again. What could be causing this?

Thanks
Bre
 

·
Registered
Joined
·
6 Posts
I have a 2015 Ford Escape and Fuse #60 kept blowing and it would kill the engine, I could restart it and drive it, but I would lose my drivers window control console and courtesy lights. I called my mechanic and he told me that I should check the wiring that goes in the vanity mirror lights, sure enough, I pulled the visor off and the small red wire was bare and touching the frame causing a direct short. I separated the black and red wires and re-taped them, this fixed the problem. It took me less than 15 minutes to fix.
 

·
Registered
Joined
·
41 Posts
I’d run down the wiring harness feeding the rear interior accessories. May have been crushed or something. You’ll need to take some things out or apart, but a short is serious and could lead to a fire.
Has there been any water issues? Leaking window seals, etc?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
I’d run down the wiring harness feeding the rear interior accessories. May have been crushed or something. You’ll need to take some things out or apart, but a short is serious and could lead to a fire.
Has there been any water issues? Leaking window seals, etc?
No leaking seals or any water issues. I will take a look at the wiring harness.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top