Ford Explorer Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
I have a '16 Explorer Sport that occasionally does something weird with the lights. I can park the car and lock it then a few minutes later the flashers and dome flights will begin flashing for no reason. This will go in for 3-5min and I'm unable to stop it by locking/unlocking the car, starting the car or and thug else. Then as randomly as it started it'll stop. Anyone else had this issue? I asked the dealer to check it and they couldn't determine a reason nor a fix.

Sent from my SM-N910V using Tapatalk
 

·
Registered
Joined
·
134 Posts
I have a '16 Explorer Sport that occasionally does something weird with the lights. I can park the car and lock it then a few minutes later the flashers and dome flights will begin flashing for no reason. This will go in for 3-5min and I'm unable to stop it by locking/unlocking the car, starting the car or and thug else. Then as randomly as it started it'll stop. Anyone else had this issue? I asked the dealer to check it and they couldn't determine a reason nor a fix.

Sent from my SM-N910V using Tapatalk
Is it acting like the alarm is kicking in? Or the panic mode, and does the horn work?
 

·
Registered
Joined
·
134 Posts
No horn, just blinking lights to include the interior lights.

Sent from my SM-N910V using Tapatalk
Being that it is all the lights I'd say it's a BCM issue. I was going to say a fuse, but not all of the lights are on the same fuse so that eliminates that. I'd disconnect the battery for 20 min then reconnect it and see if that resets anything computer wise.
 
1 - 5 of 5 Posts
Top