Ford Explorer Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello I'm new here. I hope I can get some help as it looks like there hasn't been any new posts here in awhile. OK so I am having a little trouble. Truck ran fine, no miss, when I drove it and got out. When I got back in and tried to start it, it wouldn't start like it was out of gas, cranked fine. A gentleman walking by said it sounded like a crankshaft sensor. I replaced the fuel filter, since it looked original, and that allowed it to start and run a few seconds, then when I tried to restart it was very rough. So I replaced the crankshaft sensor, had a little improvement. Now it will run 3 - 4 minutes, normal with no miss, the stall out. It is rough to restart but it will start. At this point it idles very high, 1600 - 1700 rpm, when you hit the throttle it has a slight bog and puffs a little black smoke then idles very high, ~2500 rpm, for a couple of seconds then drops back to 1600 - 1700 rpm. I have looked every where I can for a vacuum leak and can't find one. Fuel pressure regulator is good, EGR appears to be fine, I cleaned it out, MAF is clean, PCV is cleam, has a new air filter. I have turned my attention to the throttle position sensor. I done some testing with my volt meter and according to the service book I have it should only have 5 volts coming into it but mine shows 10 volts on the line coming to it. Also when I check the sensor while operating the throttle my service book says it should should show 0.5 to 1.5 volt at closed throttle and mine has 1.2, whith in range, and when operating the throttle it should slowly increase to 4.5 to 5 volts, whereas mine goes up to 9.8 volts rapidly. In my opinion the TPS is bad but my first question is, why would there be 10 volts instead of 5 volts coming in? My second question is, could this be the root of my problem since it appears my truck has too rich a fuel mixture?
 
1 - 2 of 2 Posts
Top