Ford Explorer Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello,

When Ford finally gets the computer updated, my extended warranty will run out in 200 miles. I have been waiting for a month to get the computer corrected. These are the problems I have been having and I think they are all related but I don't have enough miles left for them to say we'll see so I need to go in there with knowledge.

1. Problems started with the back up camera working sporadically. Sometimes it works and most times it doesn't and I get the warning, sometimes it is reversed (left and right are switched), sometimes there are no guidelines but I have not turned that feature off. Right now that, is the only problem but in the last month the following things have occurred.
2. Parasitic battery drain within 24 hours. I replaced the battery because it was past the warranty period. Still got a drain if not driven daily. Had the alternator checked and it was good and obviously it was good because if I drove the car everyday, there was not a dead battery. And no, there were no lights left on during this time.
3. During the parasitic battery drain period the entertainment system stopped working. Push the botton and it would come on for a second and then immediately go turn itself off. I always drive with a USB playing music and when it started acting up, it had switched itself to Line-In. It would go off so fast that I couldn't switch it back to USB. I tried several of the push this and that at the same time tricks but nothing would keep it on.
4. Bluetooth and phone would not work when the entertainment system was down.
5. Even though the key is in the off position and removed from the ignition, I will get a beep that indicates that the key is in the ignition. If I insert the key, turn to the accessory position and then turn off and remove the key, everything is fine. It has done this in the past but I ignored it. Now, with all the other electrical problems, I paid attention to it.
6. When the entertainment system started working again, the mysterious battery drain was gone.
7. The day before the entertainment system came back, I started getting the warning about the system shutting down to preserve the battery. But I never saw that warning during the period that the battery was draining.

I have parked the car waiting for Ford to get the warranty corrected but would appreciate any and all feedback so I am prepared when I go to the dealer. I have pictures of the various Sync screens and warnings but since most everything is working again, I'm afraid they will blow me off.

Thanks for your help.

Grandma Lewis
 

·
Registered
Joined
·
14 Posts
Can't say if this is the answer to your problems, but I'll give you something easy to check. On your positive battery terminal you have a secondary cable running off of it. Check to make sure that cable is tight. I have a 2015 limited and that loose cable created all kinds of havoc with the entire dash intermittingly going out, computer rebooting, etc. Never had a battery drain or camera problems but it's worth a look. Hope this helps
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Can't say if this is the answer to your problems, but I'll give you something easy to check. On your positive battery terminal you have a secondary cable running off of it. Check to make sure that cable is tight. I have a 2015 limited and that loose cable created all kinds of havoc with the entire dash intermittingly going out, computer rebooting, etc. Never had a battery drain or camera problems but it's worth a look. Hope this helps
Keith, thank you so much. I will definitely check this out as it certainly sounds promising. I've done plenty of research on the APIM module but could never really get a good answer that completely fit all the piecesof the puzzle together. This very well could be the missing piece. If I could hug you I would {{{{ }}}}}}

Grandma Lewis
 
1 - 3 of 3 Posts
Top