Ford Explorer Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
New to the forum. Just bought a slightly used 2014 Explorer Sport. Had it delivered and realized it doesn't have running boards. Should have noticed it in the pics, but would love any advice on what running boards look good/ fit well. (I have the tuxedo black version of the Sport model) Any help is appreciated!

-Eric
 

·
Registered
Joined
·
5 Posts
running boards

how much were the running boards? looks good..
They were $140 and only lower ground clearance by 2 inches
my kids love them and they really make a BIG improvement in looks overall- i think they should have been standard option
 

·
Registered
Joined
·
32 Posts
Hi, I'm new to the Explorer forum and I have a 2014 Explorer Limited in Ruby Red and I love it. The only problem I had in my first winter, I slid and skidded in the New England winter with these low profile sporty tires it comes with..I spoke to my salesman to see if I could have them changed to mud and snow all weather radials and they said no...I bought it in June'14 and almost killed my self all winter... And I love snow and cold and I usually love driving in snow and have no fear... Till now. Traded in a '03 expedition for this and had an '88 Chevy Suburban before that..I currently have 20" wheels which were too big to get any of the classic great snow tires I could get... So i had to get 18" rims so I could get Blizzaks... And I had them put on in Nov'15 and they were great although we only had 1 small snow storm all season... It's November'16 and I just put the snow tires back on, so we'll see this year whether they are really good... No other problems except a very small tear in the leather upholstery on the outer left side of drivers seat. I'm the only driver and very careful and it just appeared one day..I noticed when I was cleaning the seat... Still under warrantee and I took it into dealer and they took a picture to send to Ford.. Not sure if they will cover but I have to get it fixed regardless..I hate idea of these delicate perforated seats, but the tear was not on the perforated part.. It was on the edge where the solid leather faces the driver's door. I'm short and 120# so I shouldn't have stressed the leather and caused it. I don't have anything harsh on my pants or jackets... Anyway.. Here I am to learn and enjoy the explorer forum! Have any of you other owners had this trouble with tires in snowy locations or with testing in the leather seats from no apparent cause?

Sent from my XT1650 using Tapatalk
 
1 - 8 of 8 Posts
Top